Update auf WordPress 2.3 – Liveblogging – gescheitert

So, ich stell dann das Blog mal auf WordPress 2.3 um und ihr seid live dabei – zumindest fast. Aufgrund der umfangreichen Änderungen traue ich mich diesmal nicht ein Live-System, sei es auch nur mein Testblog Blogsprit, ohne vorherige Tests umzustellen. Alles, was ich im folgenden beschreibe kann jeder Blogger, auf ohne große PC-Kenntnisse nachvollziehen.

Grob umrissen werde ich mir zuerst lokal einen Webserver (XAMPP bzw WAMPP) installieren, dort eine Backup meines Blogs einspielen, dieses kurz testen, dann das Upgrade auf 2.3 vornehmen und dort dann die Plugins testen. Der Vorteil dieses Verfahrens ist, dass ich bei Problemen nichts kaputt machen kann und gegebenenfalls einfach „Leckt mich am Ar***“ rufen kann und darauf warten, dass jemand anderes das Problem für mich löst…

  • 14:30 Backup: Mit dem WordPress Plugin WordPress Database Backup mache ich ein Backup der Datenbank des Live-Systems, anschließend lade ich die ganzen Dateien des Blogs mit einem FTP-Programm auf meinen Rechner.
  • 14:50 XAMPP: Ich lade mir das OpenSource Webserver-Paket WAMPP (XAMPP für Windows) herunter und installiere es. Dabei lasse ich alle Optionen bei den Standard-Einstellungen.
  • 15:05 Webserver-Start: Nun beende ich meinen Skype-Client (so richtig mit rechter Maustaste auf das Icon in der Leiste bei der Uhr und Klick auf „Beenden“), weil Skype blöderweise den Port 80 verwendet, den der Webserver benutzen soll. Anschließend startet man das „XAMPP Control Panel“, startet den „Apache“ (HTTP-Server) und den „MySql“ (Datenbank-Server) und gegebenenfalls Skype (das macht jetzt keine Probleme mehr).
  • 15:10 Einspielen der Dateien: Ich kopiere das Verzeichnis „blog“ mit den Dateien meines Blogs in das Verzeichnis c:\xampp\htdocs\xampp\. Die Datei „.htaccess“ im Verzeichnis „blog“ lösche ich, um nicht später ewig nach diesem Fehler suchen zu müssen („Verflucht, warum biegt der alle meine Dateizugriffe in http://localhost/blog/blog/ um??“).
  • 15:15 Ändern der Datenbank-Daten: Ich öffne die Datei wp-config.php im Verzeichnis „blog“, und ändere die Einträge wie folgt: Der Datenbankbenutzer wird auf ‚root‘, das Datenbankpasswort auf “ (kein Zeichen zwischen den beiden einzelnen Gänsefüßchen, zu finden auf der Taste #) und der Datenbankserver auf ‚localhost‘ geändert.
  • 15:20 Anpassen des Datenbankbackups: Öffnen des Datenbankbackups mit einem Texteditor und dort per „Suchen & Ersetzen“ die Blog- und die WordPress-Adressen des Live-Systems auf „localhost/xampp“ ändern, bei mir zB von http://www.marnem.de/blog/ auf http://localhost/xampp/blog/. Den Namen des Datenbankservers auf localhost ändern (ganz am Anfang der Datei). Wenn man das Plugin „Mygallery“ nutzt
    lohnt es sich , , durch , 0, und , ) durch , 0) zu ersetzen, sonst funktioniert der Datenbankimport im nächsten Schritt nicht
  • 15:30 Erzeugung der Datenbank: Im Browser einfach „http://localhost“ aufrufen und in der linken Spalte auf „phpMyAdmin“ klicken. Bei „Create new database“ den Datenbanknamen aus der „wp-config.php“ eintragen.
  • 15:35 Import der Datenbank: Im „phpMyAdmin“ im drop-down-menü auf der linken Seite die erstellte Datenbank auswählen und dann auf „Import“ klicken, die modifizierte Datenbankbackup-Datei auswählen, gegebenenfalls den „SQL compatibility modus“ wählen, in meinem Fall „MYSQL40“.
  • 15:55 Urgs, Seitenladefehler :-(
    edit: Ich sollte nebenher auch das befolgen, was ich hier schreibe. Trotzdem hab ich noch ein Problem, nämlich wird das Blog nun zwar angezeigt, aber eine Tabelle nicht gefunden (wp210de_a ??) und innerhalb der Artikel keine „a“ angezeigt. Ich steh aufm Schlauch…
    Ok. Fehler behoben, waren alle bei mir und nicht in dieser Anleitung. Wer komische Fehlermeldungen bekommt oder beim Einloggen einen weißen Bildschirm, sollte evtl mal die functions.php in seinem Theme überprüfen, vielleicht sind da am Ende der Datei zwei Leerzeilen, die da nicht hin gehören…
  • 17:10 Wenn ihr nun „http://localhost/xampp/blog/“ aufruft, sollte euch euer Blog entgegen strahlen. Nun gehts daran, die Plugins wieder zu aktivieren und zu gucken, ob lokal alles läuft, so wie es soll.
  • 17:45 Pfft, die Plugins haben ihre Einstellungen verloren und laufen zt nicht richtig und das, wobei ich noch die gleiche Version wie auf dem Live-System laufen hab. Ach geht weg, ich mag nimmer. FRUST!

Eigentlich sollte es ja ganz einfach gehen, aber grau ist alle Theorie…

Stichworte zu diesem Artikel:

5 Kommentare ↓

#1 Samthammel am 25.09.07 um 16:08

Na wie „lustig“, ich warte lieber noch. :-)

#2 Starkiller am 25.09.07 um 16:16

Stand: 15:55
Was ich dabei nicht verstehe, wieso so umständlich, ich mein, genau für sowas hast du doch ein Testblog oder? Da gibts ja keine Datenbank an der großartig was kaputt gehen kann. So wie du es jetzt machst schaffst du dir ja noch mehr mögliche Fehlerquellen die du dann beheben musst.

#3 Marnem am 25.09.07 um 16:37

Prinzipiell ja, aber blöd Marnem hat natürlich nur nen Hoster mit einer Datenbank…
Ein Amok laufendes Blogsprit kann mir Marnem.de killen. Gestern hatte ich das Spiel natürlich schon einmal gespielt (ich blog ja nicht ganz ins Blaue), bloß hats da geklappt…
Den 15:55er Fehler hab ich gefunden, dafür kann ich jetzt nicht einloggen. Ach Scheiße das, was ich da mach.

#4 kamin blog am 25.09.07 um 18:27

Genau dieses Szenario habe ich befürchtet und deshalb werde ich voerst nicht updaten. Die Neue Version hat ja doch recht umfangreiche Änderungen im Gepäck und ich frage mich, ob die „Neuerungen“ wirklich gebraucht werden.

#5 Update Wordpress 2.3 - erst mal am Testsystem probieren « aktuelle wordpressversion « Kamin Blog am 25.09.07 um 18:32

[…] Kurz gegoogelt und was lese ich: Update auf WordPress 2.3 – Liveblogging – gescheitert […]

Hinterlassen Sie einen Kommentar


Kommentieren sie zum ersten Mal in diesem Blog? Dann wird Ihr Kommentar erst angezeigt, nachdem Marnem ihn freigeschalten hat. Bitte haben Sie dafür Verständnis.
Welche Daten über Sie gespeichert wurden, können Sie in der Datenschutzerklärung nachlesen.